Bugs

Discussion in 'General Discussions' started by sanzo, Sep 20, 2016.

  1. [KGR]-^K[o]K^-

    [KGR]-^K[o]K^- Moderator Staff Member

    It is a bug, so all people who do not activate thier games within 14 days from the release date, do not get 2 units in Diplomatic Center
    developers said: "it will be unique look (skin), that will not affect the balance of the game"

    player with early bird pack


    example:
    could combine 10 dragoons of both
    produce 5 Dragoons, 18th century mercenary
    produce 5 Light cavalry mercenary

    1. dragoon 100 gold
    2. dragoon 102 gold
    3. dragoon 104 gold
    4. dragoon 106 gold
    5. dragoon 108 gold

    1. dragoon 100 gold
    2. dragoon 102 gold
    3. dragoon 104 gold
    4. dragoon 106 gold
    5. dragoon 108 gold

    10 draggon total: 1040 gold



    player with no early bird pack
    1. dragoon 100 gold
    2. dragoon 102 gold
    3. dragoon 104 gold
    4. dragoon 106 gold
    5. dragoon 108 gold
    6. dragoon 110 gold
    7. dragoon 112 gold
    8. dragoon 114 gold
    9. dragoon 116 gold
    10. dragoon 118 gold

    10 draggon total: 1090 gold

    Imagine that difference of gold you must invest if you build 1000 dragoon...

    I do not know what else to say, if you think this is ok ...


    This exmaple is totally out of the way, it affect all players.
     
  2. [KGR]-^K[o]K^-

    [KGR]-^K[o]K^- Moderator Staff Member

    Old "yellow arrow from Cossacks back to war is back" :)

    i selected my hussars and send t

    [​IMG]

    [​IMG]
     
    Last edited: Sep 29, 2016
  3. Ebel

    Ebel Moderator Staff Member

    A bug is something that doesn't work properly or as intended.

    This is just an unfair advantage like I said in the previous post I made. I did not say that it is ok.
     
  4. [KGR]-^K[o]K^-

    [KGR]-^K[o]K^- Moderator Staff Member

    Ok so its unfair advantage then :)
     
  5. Dragonzdoom

    Dragonzdoom New Member

    What happens if you own early bird pack and after a while purchase cossacks 3 - digital deluxe? I will do that, at the time I was purchasing Cossacks 3 I only had enough to purchase early bird pack.

    Never mind, I found that I can upgrade to the digital deluxe.
     
    Last edited: Sep 29, 2016
  6. Anatotitan

    Anatotitan Active Member

    I still have the bug sometimes where the dropdown windows in the online room (where you can select the AI's difficulty or kick other players) is flickering around and hard to click on. It happens rarely, but it still happens, even though it was fixed in one of the earlier patches.

    I'd also like to mention that I still have the bug where when I click on the building/the mini map I often just select the unit BEHIND the building/mini map. The building or mini map should have priority over the unit behind that you usually can't even see.

    And setting rally points on the mini map is also still not possible.
     
    Last edited: Sep 29, 2016
    Dragonzdoom likes this.
  7. Dragonzdoom

    Dragonzdoom New Member

    Ok, I got the digital deluxe, but I still have, the original 12 nations. I upgraded to the digital deluxe does that make the 8 new nations irrelevant?
     
  8. Emperor Highlander

    Emperor Highlander Highlander Staff Member

    Hi there no, the new nations will be added in time, I think they are working on fixing the game first then add the dlc rewards in.
     
    Dragonzdoom likes this.
  9. fujy41

    fujy41 Member

  10. DennisUA

    DennisUA Member

  11. (OC)Fotheringill

    (OC)Fotheringill Active Member

    2v2 Victory bug.

    I was in a 2v2 last night. All, and I mean all, enemy troops, peasants, structures, walls and fences were destroyed. No victory message seen.
     
  12. dthstrk

    dthstrk New Member

    When you group cannons together and ask them to attack they don't fire but act like tanks without ammunition only they get captured.
     
  13. dthstrk

    dthstrk New Member

    Max built at a time is 6
     
  14. Commodore

    Commodore Active Member

    Yes the max build with shift is 6 which is not enough. But this also works with other commands, eg try grenadiers blowing up houses, or mortars. You can set them to blow up 6 buildings one after the other which is really cool.
     
  15. arsenikke

    arsenikke New Member

    Hi everyone,

    I have a macbook 12 2016 and I try to run cossacks 3 with parallels / windows 10. When I started the game I have the following error:
    [​IMG]

    Does someone have the same error ? Does someone know how to fix it ? I just can not wait the OSX version.

    If I remember well in a video 2 months ago one of the creators was playing on a macbook pro........
     

    Attached Files:

  16. Kamilow

    Kamilow Well-Known Member

    Misssing sound effect when Grenadiers use they grenades to destroy the walls.
     
  17. Zakxaev68

    Zakxaev68 Active Member

    Hey, anyone encountered the "screen freezing" issue already; comes and goes when minimizing? During I can blind select buildings, hear ambient sounds, only the screen out of sync. Somewhat fails registering my mouse movement. Steam stops me snapping a screenshot, my game ver currently 1.0.7.47.3929, Deluxe Edition player here.

    My guess performance issue. Can be anything, ranging from higher population to something interfering within the game. Should note it happens frequent when building 1000+ pop. Today I had about 4000 full pop/random map. Very odd, it appears you can skip it by pressing ESC or ENTER.
     
    Last edited: Oct 9, 2016
  18. Darkness

    Darkness New Member

    Hi,

    I have had a problem at starting game, and an error "access violation" with "openal32.dll". I've tried to install the file, the game, run in "admin mode". Nothing have worked.

    I have read somewhere, this .dll is about te sound, And i remember that i've changed some configuration at windows to use Teamspeak.
    I have changed my configuration to back at start settings, and the game has worked again. :)

    i hope i've found the true reason of my error and it will be helpful.
     
  19. xillibit

    xillibit New Member

    Hello,

    After three hours of game in single mode, the game has crashed after moving a ship. I was only able to move the mouse, by opening the task manager i had seen an error windows saying that : "error adress violation on cossacks.exe". After i had need to kill cossacks.exe process.

    My config :

    AMD FX 6100
    8 GB of RAM
    Radeon HD7870

    I hadn't used plays.tv or similar software.

    Can-you fix it please ?
     
  20. Zakxaev68

    Zakxaev68 Active Member

    ^ We both have almost related issues, talking mouse cursor changing icons. Happens about constant wherever game malfunctions in a "not responding" state. When "access violation" error pops, just hit the Enter key I mentioned early to circumvent that. Works random for me, helped once when the HUD went off and thereupon I was unable to control anything moving across the screen.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice