Syntax Error

Discussion in 'Modding' started by Yukino, Sep 14, 2019.

Tags:
  1. Yukino

    Yukino New Member

    [​IMG]
    I saw similar problem from this forum, but I forgot a link deal with the problem. So I didn't find how to fix it.
    It is clear to be error at country.script modified by me. I don't know, however, which line causes the error.
    Could you help me?
     
  2. Ebel

    Ebel Moderator Staff Member

    - start external editor, when the console window is up with the log ; right click on it
    - go to statemachine at the bottom, then select 'edit- modal', then," file - open"
    - select your .inc/script file, you may have to select at the bottom 'all files' type
    - then go to "states" at top ; and hit compile
    This should tell you the error at which line in your script, rather then line 20292 in all scripts.


    Also, why is this showing .acl files (bear, bird, etc) from my mod on top in your errors? Are you modding on top of mods, or forgot to disable other mods (maybe hence the errors?). Double check what you are doing.
     
  3. Yukino

    Yukino New Member

    I use State vs Country Plus mod. Because of State vs Country Plus mod, maybe the log viewed. I just have made State vs Country sub-mod for me and friends, so my sub-mod will not distribute other people.
    Anyway, the logging window shows Parser load errors when I attempt to load .script file. I don't know what these means. Do you know these errors?
    [​IMG]
     
  4. Ebel

    Ebel Moderator Staff Member

    Ok, my bad, that way you can't load .script files, only .aix, .inc etc. It's been a while since I looked at this editor.

    Try this:

    Go to Module on top of the editor, then select State Machines Collection near the bottom. A new window will open, click on lib.src at the bottom. Then click on States on the next window and hit compile. This should point to the problematic line.


    On another note, when the logs says 'FileStreamExists' which it does plenty in your log above, it really means it does NOT exist. It's missing files somehow (missing flagman etc...). This could be part of the problem, or a different problem, or a problem from State vs Country Plus itself.

    It may also help to explain what you are doing exactly here, in general and specifically.

    Just by having a look at line 20292 in vanilla, it appears to be a lacking definition for a unit in Turkey, but since you are building on a mod, it could be something different entirely.
     
  5. Yukino

    Yukino New Member

    Thank you for your detailed explains! I finally seem to solve the problem.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice