Patch 4-10-2016

Discussion in 'Announcements' started by Atem, Oct 4, 2016.

  1. Atem

    Atem Administrator Staff Member

    Patch Notes (4.10.16)


    1. Fixed lags with wall placing.

    2. Fixed the "Access Violation" crash that happened on maps with water, that occurred when any player tried to load his units onto ferries.

    3. Fixed random "Access Violation" crashes related to AI, that used ferries.

    4. Tuned some AI behavior related to ferries. Previously, it may have happened when a built ferry couldn't moor a coast and the game dynamic slowed.

    5. Tuned AI behavior of building ports. Now AI prioritizes it and this increases the game’s dynamic.

    6. When ordering squad to load onto a ferry, it now properly updates/removes selection from units (yellow circles on the ground).

    7. A ship are now always build at the same location near the port, ferries don’t affect it anymore.

    8. If player’s PC got 8 GB of RAM or more, all textures of buildings and models will be preloaded into memory. Previously, only initial buildings were preloaded. This should remove lags and stutters while a player moves his camera over enemy city, destructs buildings or builds high-tier buildings.

    9. Fixed some bugs in French localization: long names on buttons, text names and description for tutorial campaign missions.


    1. We’ve fixed the occasional desynchronization of time between a host and players. From now on the game speed is the same for everyone. This also fixes the bug with invisible armies, strange behavior of peasants and lag in response of some units.

    2. Peace Time is now displayed correctly for everyone.

    3. Peace Time won’t appear in matches where it wasn’t set anymore.

    4. For MP, we’ve changed a behavior of ESCAPE button and a “Close” button in the victory/defeat message. Now they close the message and allow to continue the game as a spectator while Backspace buttons disconnects you from the match.

    5. We’ve implemented 4 new messages for various situations in the multiplayer. Now the game will notify everyone when: a host quits the session and the game cannot be continued; when a host loses his connection; when a player quits; when a player loses his connection.
  2. game_theory

    game_theory New Member

    The desynchronization and peace time fixes are nice.

    Still in 'very fast' mode the game-timer (and peace time) runs faster than a real second.
    So for example 20 minute peace time is shorter than actual 20 minutes (its only 14 minutes).
    Is that intended behaviour?
  3. Commodore

    Commodore Active Member

    i noticed that, thought it was just me. As long as its the same for everyone in the game it doesnt matter too much.
  4. Nath33killer

    Nath33killer Member

    I just played a multiplayer game and my mines were captured. I wasn't able to recapture them is it normal ?
  5. [KOR]King

    [KOR]King New Member

    When can we expect ranked in multiplayer please?
  6. Masher

    Masher Active Member

    Nice fixes.
  7. smoky

    smoky New Member

    i got the same question ... and i have many would be nice if there is any guide with everything ... i did pay for the game so i would wish there is something to read about the countries etc.
    Ioannis84 likes this.
  8. Masher

    Masher Active Member

    Still getting access violation crash on water maps. I put 7 players impossible a.i to test their ferry behaviour and still crashing with that error. Seems to work fine on land maps though. Odd.
  9. Nath33killer

    Nath33killer Member

    I played a multiplayer game and I trained king's musketeers (I played France) and I took a group of them to harass my enemy. Suddenly when I fired all my king's musketeers died in the same time. It looked like their own shot killed them. Do you have any explanations ?
  10. Emperor Highlander

    Emperor Highlander Highlander Staff Member

    Was Peace time on?
  11. Masher

    Masher Active Member

    Sounds like you attacked a player during peace time.
  12. Nath33killer

    Nath33killer Member

    Omg that's surely the issue thank you guys I'm sorry
  13. Commodore

    Commodore Active Member

    yes it must have been peace time, but it might not be your own fault. Sometimes the peace time seems to get out of sync and there is no way of knowing that i can tell. There is still a lot of lag in multiplayer.
  14. Ftoomsh

    Ftoomsh Well-Known Member

    There is a bug where damaged mines cannot be repaired. If you upgrade even a slightly damaged mine, then you cannot repair it. And if you cannot repair it, then you cannot get more miners to go into it. Ouch! That hurts the gold supply!
  15. Zakxaev68

    Zakxaev68 Active Member

  16. Hansol333

    Hansol333 Active Member

    hey I havent played the last few days

    I stopped because there were to problems that made me crazy,

    1) if you auto train units to location x they ALWAYS go there, even if a unit attacks them, thats looks so stupid if they are attacked by melee cavarly but still continue moving

    2) sometimes units just stand there and do nothing. that is extremely annoying of these are slow trained or expensive units

    Are these 2 problems solved so far?
  17. Nath33killer

    Nath33killer Member

    Wtf ? I don't understand the matter, it looks normal.
  18. Commodore

    Commodore Active Member

    no , those two problems are still in the game. You have to keep your troops moving and attacking or they seem to lose interest and just stand there getting shot at.
  19. Ftoomsh

    Ftoomsh Well-Known Member

    If this game is anything like C1, it implements an attack response range for units. If something out of range hits them then they attack unless they are on stand ground or the no attack (stand down) setting. All units by default should be on attack settings. However, too long an attack response range setting can be bad too. If units get hit by distant cannon you do not necessarily want them to walk on attack and walk right into canister fire (often incorrectly called grapeshot). They can do this if you forget the stand ground setting when under distant cannon fire. Maybe in C3 they have altered the attack response range for units. I don't know.

    Shooting units sent to a gather point have never fought while moving there as far as I remember in C1 or C3. I think cold steel units sent to a gather point will fight on the way. But I would have to check that.
  20. Ftoomsh

    Ftoomsh Well-Known Member

    I am shut out of Multiplayer. My game which worked perfectly well yesterday will now NOT connect to the multiplayer server. Each time I attempt a connection, it will not connect and tells me, after a delay of about 10 seconds, that my connection is lost. I do not even get the chance to pick server 1 or 2. I had Skype advice from a contact that the shell was up when I was attempting to enter multiplayer. So the question is, what has changed?

    1. I checked my firewall permissions. They are still the same and all correct for Cossacks 3.
    2. I checked my Steam account to check it was not stolen or hijacked and that I still had Cossacks 3 in the library. All looks correct.
    3. I started the game as administrator to make sure all was correct from that point of view.
    4. I checked the game in Random map mode. It still works perfectly.
    6. I rebooted and tried again. Did not work.
    7. I checked my other steam game, Forged Alliance was still working for multiplayer and it is.

    Other information.

    A. I run Windows 10. It is all up to date.
    B. I have a NVIDIA Geforce Experience Graphics Card. It has one update available which I have not run yet.
    C. My internet connection is the same it has been since I started running Cossacks 3 in multiplayer.
    D. This connection is a Cisco ADSL2 router.
    E. I am not aware that my ISP has changed anything about my connection.
    F. All the rest of my internat connections to web work the same as before.
    G. An Ookla speed test shows my connection speeds are just the same as they ever were.

    Can anyone help me? Answers would be much appreciated, thank you.

    UPDATE: My Cossacks 3 game details have been passed to Atem so if it is a game issue I am sure Atem can fix it. I just hope my ISP (Internet Service Provider) has not changed my internet connection in some way.
    Last edited: Oct 8, 2016
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice